注意安装zlib-devel
参考:

  1. Centos7安装PHP7 zipArchive支持

  2. Centos7 安装zipArchive及libzip 版本更新


安装:

yum install -y php-devel #用于编译
cd /usr/local/src
wget http://pecl.php.net/get/zip-1.15.3.tgz  
tar -zxvf zip-1.15.3.tgz

cd zip-1.15.3  
phpize
whereis php-config
./configure --with-php-config=/usr/bin/php-config123456789

报错:configure: error: Please reinstall the libzip distribution
最新版本请参考官网:https://nih.at/libzip/ ,libzip 需要 cmake 。

yum install -y cmake
cd ../
yum remove libzip
wget https://libzip.org/download/libzip-1.2.0.tar.gz
tar -zxvf libzip-1.2.0.tar.gz
cd libzip-1.2.0.tar.gz
mkdir build && cd build && /usr/local/bin/cmake .. && make && make install1234567

又报错:

CMake Error at CMakeLists.txt:4 (CMAKE_MINIMUM_REQUIRED):
  CMake 3.0.2 or higher is required.  You are running version 2.8.12.2
-- Configuring incomplete, errors occurred!123

cmake版本过低,需新版本。

yum remove cmake
yum install -y cmake3
cmake -version123

OK,cmake环境版本升级完毕。

然后再编译 zip 。

cd ../zip-1.15.3
./configure --with-php-config=/usr/bin/php-config
make
make install1234

安装过程中若出现
    fatal error: zipconf.h: No such file or directory
使用命令:

find /usr/local -iname 'zipconf.h'
ln -s /usr/local/lib/libzip/include/zipconf.h /usr/local/include12

然后再执行一遍安装即可。最后用命令查看有没有zip.so文件。

ls  /usr/lib64/php/modules/1

修改 /etc/php.ini :

zlib.output_compression = On
extension=/usr/lib64/php/modules/zip.so12

重启 apache:

service httpd restart1

再查看 phpinfo,就有 zip 扩展了。

zip model

0 个人打赏                            


版权声明

1、本类目资源来自互联网收集,本站不保证资源的完整性及可运行性,资源仅供用于学习和交流,请勿用于商业用途。如有侵权、不妥之处,请联系站长并出示版权证明以便删除。敬请谅解!

2、本资源为虚拟可复制性,下单后不予退款,谢谢您的支持!

3、关于本站资源版权的免责说明(下载本站资源即表示你已经阅读)。

4、对于不当转载或引用本网站内容而引起的民事纷争、行政处理或其他损失,本网站不承担责任。

5、对不遵守本声明或其他违法、恶意使用本网站内容者,本网站保留追究其法律责任的权利。

唯一网址: http://www.2min.cn/14_110.html

上一篇: 使用cmake3编译安装libzip

下一篇: ptcms4.2.8搬家教程以及不采集解决?

用户评论 (0)

暂无评论

嘿,我来帮您!